Error when trying to sync

I just created an account and successfully linked my Google drive, but when I click "Start synchronisation," I get


Slim Application Error

A website error has occurred. Sorry for the temporary inconvenience.


Any ideas what's going wrong?

Comments

  • Same problem for me - I just signed up yesterday (22 Aug 2020).

  • KoenKoen Administrator

    The most common reason seems to be that the token was copied incorrectly, which means it is malformed, and it does not work. After re-authenticating your storage it should work. A better error message should be coming soon(ish).

  • edited August 23

    Okay, got it, thanks. The problem was I was copying just the access_token String, not the entire response. Seems like it's not a common error if no one else has run into it yet, but it might help to add something in the UI about needing to copy the entire thing.

    The sync is running now but failing immediately with:

    F_ERR  cURL error 35: OpenSSL SSL_connect: SSL_ERROR_SYSCALL in connection to www.googleapis.com:443  (see https://curl.haxx.se/libcurl/c/libcurl-errors.html)
    

    which is apparently "A problem occurred somewhere in the SSL/TLS handshake." I tried to stop the sync and try again just to see if it was consistent, but stopping didn't seem to do anything and trying to start a new one says the previous one is still running.

    edit: It did stop eventually, I guess I just needed to wait! Still not sure if the SSL error is significant or not.

    edit edit: Whoops, I should have read the fine print about not being able to sync more than once every three days. :( Might be nice to throw that up as a warning when someone tries to stop a sync.

  • KoenKoen Administrator

    @sweetmilkpocky Sorry about that. Your timing seems to be quite unfortunate. The synchronisation server was having some connection issues, which is what the error shows. Normally, when the synchronisation process gets stuck or crashes for some reason, that will be detected, and the three day limit will be reduced to three hours, and/or it will recover automatically (depends a bit on the circumstances). However, because you stopped it yourself, the three day limit does apply, because otherwise people would stop just before the end.

    Anyhow, it should now be working again, and your sync should be running again (this time hopefully without errors). Plus, you should receive something else per email shortly.

  • Aha! Yes, the problem for me was that I didn't copy the entire token string when connecting to Google Drive. Now I have done that and sync is working. Thanks!

  • @Koen Ahhh, thank you for the explanation! I thought it might be hanging after the error (but I only waited ~30 seconds) so I killed it, but that's good to know in case it happens again. And I checked my email, thank you! :) Can't wait to really give Astiga a try!

Sign In or Register to comment.