Webdav works, but not only subdirectory

Hi,

I have experimented somewhat with Astiga using Google Drive and was quite pleased with the results. But because of the storage limitations Google implements I was looking for an alternative. I have an account with enough storage at a local provider (Transip Stack) which is accessible through WebDav.

I can get it to work, but only when I let it sync from the root directory. When I specify a folder in the Sync-process I get an error:

The folder 'Muziek' could not be synced because an error occurred.

Check whether your storage settings are correct.


The details of the error give me no clues, except for a 401 code. Which is strange because the authentication works fine without the subdirectory.

Any idea what goes wrong here?

I'd like to let it sync only a subdirectory with music files if possible. Is there a way I could make that work through WebDav?

Thanks in advance.

TtV

Comments

  • KoenKoen Administrator

    I'd recommend setting the initial folder to your music folder, which would probably be something like /remote.php/webdav/Muziek That way you can later just sync the root folder. If you want to manually sync a folder, that is possible too, however, it once again requires the entire path, which would in your case also be /remote.php/webdav/Muziek

  • Hi Koen,

    Thank you for your advice. It works like a charm!

    I was pretty sure I already tried setting the initial folder to the Muziek-directory and concluded that it didn't work. But that was probably when I hadn't realised yet that the Webdav URL was split in a base URL followed by an Initial folder field. I pasted the complete URL in the Base URL field.

    Thanks again! Astiga seems a nice place to play my MP3 in the future now Google Play Music is going away...

    TtV

  • KoenKoen Administrator

    TransIP's Stack (and other storage providers based on ownCloud) have that quirk. Normally / refers to the root folder, but not in the case of ownCloud and NextCloud. The entire URL works for the main folder, but then it gets confused when it comes to subfolders. E.g. can Muziek/Beethoven be found under https://example.stackstorage.com/remote.php/webdav/Muziek/Beethoven or https://example.stackstorage.com/Muziek/Beethoven ?(The answer is the former, but Astiga will try the latter)

    It can be "fixed", but that would likely cause issues with WebDAV servers that have "interesting" folder structures (so folders that have shortcuts to other folders in them), hence this solution.

    However, I am interested in how you managed to enter the entire URL in the Base URL field. You are by far not the only one, hence I added a check to make sure you do not include the path. If it doesn't match, then your browser should kindly request you to use the requested format:

  • Hi Koen,

    I just pasted it in the Base URL field (my fault of course, because I didn't pay attention to the hints in the fields). So I pasted "https://example.stackstorage.com/remote.php/webdav/" in the base field and added "Muziek" after it manually.

    So it looked like this: "https://example.stackstorage.com/remote.php/webdav/Muziek"

    Astiga accepted it, but sent me an error when I tried to sync.

    I also tried it by adding a forward slash at the end so "Muziek/". So like this: "https://example.stackstorage.com/remote.php/webdav/Muziek/".

    With the same result, the 401 error.

    Hope this helps.

Sign In or Register to comment.