Connecting to Google Drive / Shared Drives

ArneauxArneaux Member
edited September 28 in Storage

When tryin to set up a connection to my Google Drive folders, I'm failing to get it right, getting errors like this all the time:

{ "error": { "errors": [ { "domain": "global", "reason": "notFound", "message": "File not found: .", "locationType": "parameter", "location": "fileId" } ], "code": 404, "message": "File not found: ." } } array ( 0 => array ( 'domain' => 'global', 'reason' => 'notFound', 'message' => 'File not found: .', 'locationType' => 'parameter', 'location' => 'fileId', ), )

I have a drive on my PC synced with Google Drive, in Drive it's in the "Computers" / "PC" section.

As recommended somewhere, I also made a shortcut of the music folder to a folder in "My Drive".

Trying to set up a connection, I used the "get link" option when right-clicking the folder, the shortcut and the shortcut where the folder is in. This link was then copied in the "initial folder" box, but without all the extra text, so I deleted "https://drive.google.com/drive/folders" and "?usp=sharing". What remained was just a string of characters.

I also tried to copy this in the optional box "root", since my music folder is in a shared drive. Same result..


I guess I'm doing something wrong, but I don't get what.. Can you please advise me?

Post edited by Arneaux on

Comments

  • I am going to be connecting Google Drive in the same way - pointing it to a folder in the "Computer" section. I will feedback here on if I get the same error.

  • KoenKoen Administrator

    Did you add a shortcut or did you add that folder to My Drive?

    The top one is added to My Drive, the bottom one is a shortcut (confusing, I know). In case you did the latter:

    If you go to the folder, then press Shift + Z, you should see this popup:

    It looks very similar to the "Add shortcut" popup, except that it is green. If you then add it to My Drive, you should see the folder in My Drive as well with the top icon (so the icon with the person inside the folder). Then you can add it to Astiga using:

    (with your token of course)

    More than one road leads to Rome, but I think this is the easiest path.

  • ArneauxArneaux Member
    edited October 3

    Hi Koen,

    Thanks for your reply. Somehow I can't get Google to do what you showed.

    Shift+Z on the folder that I want to add to My Drive gives another menu than in your example (thought it is green).

    In your example you have the options to add the folder to "My Drive" and to "Computers". In my case, I have the options "PC" and "Computers" (which is in fact the same, since "PC" is a sub of "Computers" . I have no option called "My Drive".

    So I guess, I have a Google Drive issue ;)

  • KoenKoen Administrator

    Great, then there's option B:

    If you open the folder you want to add in Google Drive, you should see an URL like this:

    If you then copy the obscured value to the "Root folder" field (so everything that comes after folders/, e.g. eeKm5j0xYrHb5Fzdn-L5J5gPSkd80XqK), and set the "Initial folder" to /, then it should work as well.

  • Thnx!

    Seems to be working just fine now.

  • This worked for me, too. Thank you, Koen.

Sign In or Register to comment.