Some audio files break at seemingly random

CambionnCambionn Member
edited April 2 in Bugs

So every now and then, there is an audio file that Astiga did synchronise correctly, but refuses to play. Sometimes after resyncs this fixes/changes itself. Currently, Itzy's Ting Ting Ting and Bruce Springsteen's This Hard Land give this error. They show up and can be added to the playlist, but it refuses to play and instead Astiga just stops at the song until selecting another one that does work.

I always rip audio per CD yet it are single files that break, and the files play well everywhere else, so I doubt the files itself are the issue.

Post edited by Cambionn on

Comments

  • Didn't even resync and while the files wouldn't play yesterday no matter what, now it suddenly works today. But this happens every now and then and I'm not sure why.

  • KoenKoen Administrator

    So syncing does not affect the ability to play - syncing populates the library, so that your albums, artists, etc. show up. But you can play your audio files without syncing just as well using the file browser; they will always be retrieved from your storage.

    What probably happens is that Astiga has trouble getting the file from your storage (e.g. OneDrive) for some reason, and then skips to the next. Why that happens, is what I am looking into now.

  • CambionnCambionn Member
    edited December 2020

    I also noticed that lately, Astiga often doesn't tell me it adds stuff to the library. Like, it stays a long time stuck on get [the last folder], then says end. However, when checking items are synchronised.

    Also, sometimes, it seems like new items aren't recognised until between half an hour and an hour after they are added to the drive. For example today, I got 4 CDs in tonight so I added them to the drive, but only the first 3 CDs where added. And a few days ago, I added some Christmas songs, but it didn't want to add them until much later the evening.

    This both weren't issues before, but started a few days ago.

    Considering all my files are on Onedrive, I'm just as willing to believe Microsoft changed something rather than it being Astiga, but it seems worth mentioning, because now I end up resyncing many times in hopes it finally picks up, which is a bit a bother.

  • KoenKoen Administrator
    edited December 2020

    It is true that your folder content is cached for up to an hour, so it might not appear directly. The reason is that the way Astiga treats folders and the way OneDrive treats folders are not the same, and with caching it is significantly faster. (Astiga is stateless and based on a path, whereas OneDrive is stateful and based on a tree; one can be turned into the other, but that is not necessarily efficient)

    There is no indication that a folder is cached at the moment, but you will notice it in the time it takes to get that folder's content (namely milliseconds instead of seconds).

    So if you added your files within an hour of syncing, then they may not show up.

  • I see. Thank you for the explanation. I was really getting frustrated trying to resync in the most forced ways I could think of, even sometimes deleting the entire drive and resync just to try to get around it, not knowing why it wasn't synchronising. Good to know I just need to be a little more patient. The syncing has improved a lot in speed compared to when I started to use Astiga.

  • CambionnCambionn Member
    edited March 5

    "What probably happens is that Astiga has trouble getting the file from your storage (e.g. OneDrive) for some reason, and then skips to the next. Why that happens, is what I am looking into now."

    This issue is reappearing again. Around half pas 12, for a few minutes none of the files wanted to play but then it slowly started working again. Some files still refuse tho. Even more weird, Astiga also randomly decided a song that's 3:09 is 13 seconds, and plays only the first 13 seconds as if it's the whole file. Didn't have an issue for long time since making the topic but today files that worked yesterday and that I didn't touch since got these issues. The webplayer just endlessly pauses, stops after x amount of seconds thinking the song is finished, or plays broken tracks twice (restarting them after breaking halfway and moving to next track the second time it breaks).

    Have you ever found a solution/cause? Even now, 1,5 hour later, I can't properly listen to music. Over half the tracks are either broken halfway or don't play.

    Post edited by Cambionn on
  • KoenKoen Administrator

    @Cambionn That was caused by another issue, which is now fixed. Namely that the volume the temporary folder is on was full, thus your files would arrive partially (until the disk was full), or not at all. Normally I prevent that from happening, but it turns out this volume was not included in my monitoring, thus I did not notice it.

  • CambionnCambionn Member

    I see. Good to know. It indeed works again, thanks!

  • poyopoyo Member

    Reviving this thread: this has been happening to me for about a week now, specifically with each song from some specific albums of mine (streaming from my personal Google Drive, which holds basically all my music.) Everything else works but the songs from this album simply don't play, like op's problem; the tags load and I can add/remove its songs from my playlists but it doesn't load the songs themselves and refuses to play them. I've tried reuploading it to my Google Drive and resyncing it, removing then readding the same album, and the issue hasn't been fixed on my end, as far as I can see..

    I'm using the web player on Google Chrome if that helps; and as far as I know this only happens to a small handful of albums I have although nothing's worked to locally fix it.

  • KoenKoen Administrator
    edited March 18

    @poyo If it always happens with the same files, then send me an email (koen@asti.ga) and I will look into it. That might be due to a different issue (e.g. file name, or specific codec issues etc.).

    Post edited by Koen on
  • CambionnCambionn Member

    Earlier today I had a lot of songs randomly stopping at exactly 2/3, as if the song was only buffered so far but not further. Then after seconds of silence suddenly continuing. Obviously not a nice way to listen to music when more than half the songs do this. I'm not sure if it's related or not, but both the original issue and this seem to be somewhere about the files having to be loaded/buffered from the server.

    Later tonight I didn't have an issue, so maybe it was temporary or it's already solved. But I figured it might be worth mentioning.

    These kind of issues have also only been present at the web player btw. The phone app never seems to have issues.

Sign In or Register to comment.