SFTP storage appears blank to Astiga

vnpvnp Member

When trying to connect to a SFTP storage, I can add the storage without any errors, but when trying to synchronise, Astiga reports that there aren't any files or folders.

The SFTP storage is accessible over the internet (using password only not RSA key), and using the same SFTP information FileZilla can connect to the SFTP and browse contained folders and see mp3 files.

I tried pointing Astiga to /, /music, and /music/TEST but got errors each time:

The folder '/' does not seem to contain any files or directories.

The folder '/music' does not seem to contain any files or directories.

The folder '/music/TEST' does not seem to contain any files or directories.


Since Astiga is not showing any errors (other than 'no files/folders') is there anything I can do to troubleshoot the connection? Has anyone else experienced this before?

Any help/advice is appreciated.

Best Answer

  • Accepted Answer

    Astiga makes very few assumptions. That is however something that does tend to go wrong.

    Anyhow, I looked into it, and are you sure that you have an IPv4 address that belongs to you only (and you entered it correctly)? Because the address you entered belongs to a Carrier-grade NAT reserved block, which would imply that you share that IP address with other users, thus cannot port-forward your router to accept requests on port 22. If so, you might want to see whether your ISP also provides an IPv6 address that you can use instead (which I believe you would have to enter in brackets notation, i.e. [1234:5678:90ab::cdef]).

Answers

  • KoenKoen Administrator

    Are you sure that the "music" folder is directly underneath the root folder according to your SFTP server? FileZilla will directly open the home directory (in the status panel at the top, you should see "Connected to w.x.y.z", and after that "Listing directory /a/b/c"), but Astiga uses the path relative to the root, not the home directory. So it may be that the actual folder is /home/bob/music (or something the likes), instead of /music. At least, I believe this is the case with OpenSSH. That would explain why there are no files/folders shown.

  • vnpvnp Member

    Thank you for your response.

    I did some more troubleshooting without any success.

    The actual server folder structure is /home/bob/music/TEST. Each folder (/bob, /music, /TEST) has at least one mp3 file in it.

    The FileZilla interface/status does show "Connected to w.x.y.z" and "Listing directory /".

    The user 'bob' is configured to only have read and execute access to /bob and subfolders. bob has no access to /home. The home directory for bob is /bob which is configured as the initial folder for bob. When I use FileZilla /bob (appears as /) is the initial folder shown and bob cannot navigate above it (/home is not visible or accessible).

    Based on your feedback, I tried setting up SFTP storage for Astiga to be /home, /home/bob, /home/bob/music, /home/bob/music/TEST, /bob, /bob/music, /bob/music/TEST, but each resulted in the same error message (no files/folders found).

    Is Astiga 'expecting' that all users connecting to a SFTP storage have access to /home?

    I appreciate your help with this.

  • vnpvnp Member

    That was it. Carrier-grade NAT is causing the problem preventing connection.

    Thank you for your help identifying the issue.

Sign In or Register to comment.