Bug or Have I Messed Up? - ERROR This File Does Not Appear to Be An Audio File

JudJud Member

I have just signed up for Astiga and pointed it to my B2 bucket of about 10,000 audio tracks, a little over a TB. There may be a handful of mp3 tracks in there, but the vast majority are AIFF in resolutions from 16/44.1 to 24/192. There are also a number of DSF (DSD) tracks, some WAV, and some FLAC. There are also JPGs and PDFs (cover art and booklets). It appears that on the initial sync of the library, for virtually every audio track (I won't know if it's literally every track until sync completes), I am receiving the message "ERROR This File Does Not Appear to Be An Audio File."

Is there something I'm doing wrong, and if so how do I correct it?

Is this possibly a bug, and if so how can I best assist in fixing it?

Thanks.

Comments

  • JudJud Member
    edited July 23

    Something helpful(?) that I have now seen upon expanding the Astiga log window: "Received error from B2: accountId invalid" for each of the files.

    

  • KoenKoen Member, Former

    That's peculiar. Just to be clear, you generated a key like this, right?


    There have been some odd quirks in the past when it came keys that had access to too much (specifically master keys). Additionally, if your Backblaze bucket is relatively young, you can also add it using S3. Do you happen to know which region your B2 account is? (Mine is in the original US region, there might be something I need to do differently for the EU data region).

    I just tried creating a new key for myself, and it worked without issue, so if that does not fix the issue, then something else may be going on.

  • JudJud Member

    Read and write access is the only difference I see offhand. It's an application key rather than a master, US region. Before you worry overmuch about this, let me wipe out this installation and try creating a new app key, since it's possible I messed up some setting when installing the first time. I'll choose read only this time also.

  • JudJud Member

    Tried again, checked things twice - still no joy. Astiga lets me create and sync the library; the directory structure is all there (B2 bucket/artist folders/album folders/music files); but I still get the same error messages in the log. Attempting playback produces a couple of seconds where the UI looks like it's trying to play the file (changes from Play to Pause icon), but no sound and then it falls back to the Play icon.

    I can access and modify the bucket with rclone and ChronoSync, so I've done the application key process successfully for those apps. It's puzzling.

  • KoenKoen Member, Former

    I think I have managed to reproduce it - can it be that your key is not limited to access to a single bucket, but instead has access to every bucket? Because I have created a new key for myself without it being limited, and it seems to have the same issue.

    If so, then I believe I also found the reason. In the call to get the authorization key to access your folders/files, the bucket name and ID are also returned if access is limited to a single bucket. This data is later used to convert the bucket ID to the name, and if it is missing, it seems to cause some issues. (The bucket name is used for downloading a file, the bucket ID for getting the folder content, hence browsing works, but playing a file does not)

    Could you try that?

  • JudJud Member

    That sounds like it. Will test when I get back home next weekend. (Camping in Colorado. 🙂)

  • ColumboColumbo Member

    I've had this issue too, a lot of mp3 files have flagged the problem though and won't be synced.

  • KoenKoen Member, Former

    @Columbo The error comes up whenever the file could not be identified as a file containing audio. There a quite a lot of different reasons that this could happen, for example:

    • The file failed to download properly, and is only partially downloaded/not at all downloaded
    • The file actually is not audio, but video. This is the case for some audiobooks or audio files where the album art was added as a video track. Because Astiga is for audio and not for video, these will not be synced.
    • The file is in a format Astiga cannot handle. This is the case with midi, which gets detected as audio, but when parsed is then rejected.
    • The file is listed but not downloadable, e.g. if you have a wrongly configured WebDAV share that shows a file, but when one attempts to download it, it will give an error.

    So in this particular case it seems to be that the fourth case, namely that Backblaze shows the list of files, but when Astiga tries to download the files, it cannot do so because it assumes information is there, when it is actually not. Luckily it can be worked around by creating a narrower key, which is actually preferable anyway from a security perspective.

  • JudJud Member

    Back home and things look good so far. No error messages and taking time to load my collection (10K tracks, many of them large) like my home installation of Subsonic. Not planning to try playing anything until it's all done loading.

  • JudJud Member

    Hmm, things appear to have halted:

    2021-08-01T21:20:41 FAILED Boston Symphony/BSOCL1401_WagSib_01_HD.aif
    2021-08-01T21:20:41 ERROR  Could not write to the database
    2021-08-01T21:20:45 FAILED Boston Symphony/BSOCL1401_WagSib_02_HD.aif
    2021-08-01T21:20:45 ERROR  Could not write to the database
    


  • JudJud Member

    Weird. Waited a while, hit Sync again, and now those same tracks have been added without incident. Time to let this run overnight so as not to raise any more premature alarms and come back in the morning to see what happened.

  • ColumboColumbo Member

    @Koen Thanks for the response. How do I create a narrower key?

  • JudJud Member

    Not Koen, but 'narrower key' for Backblaze B2 means that when you are creating the application key you do not select the option to have it open all buckets, but only one. (In my case I only have one bucket containing my music, so that makes it easy.)

  • ColumboColumbo Member

    Bucket meaning the source of my music? I've got it all one place on pCloud. Sorry I'm not very good at this stuff.

  • JudJud Member

    Don't know about pCloud as I've never used it, so obviously Koen would be a better source for specific information. I can just say generally that you can store files in different "buckets" in Backblaze. In order for Astiga to work correctly, the application key must be created so it only applies to a single bucket. Whatever the equivalent of that would be in pCloud....

  • ColumboColumbo Member

    Ah I see, maybe it's similar with pCloud then. Weird as the problem files have been fine up until the last sync.

  • KoenKoen Member, Former

    @Jud I updated the servers yesterday, which required a reboot, which halted the ongoing syncs (including yours). Don't worry - the system automatically detects and restarts them within 4 hours.

  • KoenKoen Member, Former

    @Columbo The way pCloud works is quite different from the way Backblaze B2 works - if you do experience any issues with pCloud, then feel free to create a new discussion for that, and it will be looked into.

  • ColumboColumbo Member

    Will do, thanks

  • JudJud Member

    Log file looks good this morning. Will look into playing something later today.

  • JudJud Member

    Success. Happily playing music over AVSub and play:Sub. Thank you!

Sign In or Register to comment.