Songs abruptly cutting off

Lately I've had a lot of trouble with tracks abruptly ending and going on to the next one, even though it shows time left on the song. I can play them fine on my laptop, so I wonder if it's a connection issue, but the problem persists on mobile even when I'm back on wi-fi. I'm syncing from Google Drive. Anyone else have a similar issue?

Comments

  • gravelldgravelld Administrator

    Does it happen with all tracks? Does it happen with about the same amount of time left on the track?

    When was the last time you were playing and this happened? I'll check the logs.

  • Anyone else have a similar issue?

    A few times, but rarely on the overall amount of tracks played. Like when I'm having music on all day (about 8-10 hours at "worst" times) it may happen once or twice max, if it does at all. Using OneDrive myself. It seems a bit random which track, and the same track might work fine next time it's played. When I go back to the previous track the last part can also play, so to me it seems to be an issue during playback issue more than a synchronization-related one. If the issue is on the cloud service's side or Astiga I cannot tell.

  • gravelldgravelld Administrator

    Thanks for the datapoint 👍️

  • Hey thanks for the response! It doesnt happen with all tracks, maybe one or two times out of 15 tracks? And it could well be a connection problem as I'm usually listening while driving. I haven't noticed that it cuts off after any or before any particular amount of time.

    I made sure to check the time when one cut off on me this morning -- 8:16 a.m. EST.

  • gravelldgravelld Administrator

    @honeycrema Was this a track by an artist called "Murder By Death"? If not, could you say the artist, or track name?

  • It was the track "HELLO (Album mix)" by Hyde.

  • gravelldgravelld Administrator

    Currently, M4A files are converted to FLAC before they are streamed to the browser.

    I can see there's a warning in the logs about converting that file:

    [flac @ 0x559e823cab80] Frame rate very high for a muxer not efficiently supporting it.
    Please consider specifying a lower framerate, a different muxer or -vsync 2
    [flac @ 0x559e823dda00] encoding as 24 bits-per-sample
    

    If I manually convert it, I get the same errors. The file plays fine when downloaded and played with the whole file. However, that's not how Astiga actually streams audio, instead it uses HTTP chunking of the file.

    I also tried converting by specifying -vsync 2 -sample_fmt s16 . I don't think the original should be a 24 bit file right? This makes for a smaller file which might make for a lower chance of this happening.

    Still, I'm not sure where the issue lies. I suspect the most likely issue is a memory one... I'll look into sorting that asap.

  • I fully confess that the tech part of that is totally over my head. The bit rate in the file properties says 263kbps but I'm not sure if that's the info you need. Thanks for looking into it!

  • gravelldgravelld Administrator

    No worries - I didn't mean to require you to understand that, it's more about full transparency if someone searches for this in the future.

Sign In or Register to comment.