Astiga works perfectly except for one album which won't play

gDermgDerm Member

Hi

As per the title , Astiga works great for me except for one album.

It plays on the Astiga app in androind on 2 devices i test.

But it does not play in Chrome or Edge on two different PC laptops , or in chrome on a mac laptop.

I have cleared cache and cookies etc.

My account is linked to OneDrive, and I can download the files without problem from OneDrive.

The album appears in the Astiga import log.

It has no unusal characters in file name.

I"m totally stumped , its my kid's favourite (raffi- baby beluga)

Any and all advice appreciated thanks

Comments

  • gravelldgravelld Administrator

    its my kid's favourite (raffi- baby beluga)

    Better get this sorted then 😀

    In Chrome, can you:

    1) Open Developer Tools (Ctrl+Shift+I)

    2) Click Console.

    3) Try playing the track

    Are there any red error messages that come up? Can you copy/paste them? If it's easier you can right click and Save as....

  • gDermgDerm Member

    Hi

    Thabnks for trying to help.

    There are error messages:

    Failed to load resource: the server responded with a status of 403 (File does not seem to contain audio) https://play.asti.ga/get-file/GeorgeOneDriveMusic?file=_GrdArchive%5CMUSIC%2F_GrdArchive%2FMUSIC%2FRaffi%2FRaffi%20-%20Everything%20Grows%2F01%20Bathtime.mp3

    But, the file downloads and plays fine from one drive.

    Another one that worked jsut yestderday now won't play and says

    '

    Uncaught (in promise) DOMException: Failed to load because no supported source was found. https://play.asti.ga/get-file/GeorgeOneDriveMusic?file=_GrdArchive%5CMUSIC%2F_GrdArchive%2FMUSIC%2FRaffi%2FRaffi%20-%20Everything%20Grows%2F07%20Eight%20Piggies%20in%20a%20Row.mp3


    There are other messages also that come up as soon as I load Astiga (I cleared the console , then loaded Astiga)

    Perhaps these are normal but copying them anyways:


    DevTools failed to load source map: Could not load content for https://play.asti.ga/css/bootstrap.css.map: HTTP error: status code 404, net::ERR_HTTP_RESPONSE_CODE_FAILURE


    DevTools failed to load source map: Could not load content for https://play.asti.ga/js/aurora/aurora.js.map: HTTP error: status code 404, net::ERR_HTTP_RESPONSE_CODE_FAILURE


    thanks!

  • gravelldgravelld Administrator

    In the app, were these files pre-cached and on your device?

    Is it possible to download and share one of these files with me? You could email me a shared link to info@asti.ga .

  • gDermgDerm Member

    Hi

    Yes, i think they were pre-cached. The android devices stopped working.

    I will email you the files.

    For what its worth, i already know the files download from onedrive and play just fine. They come from ripped cd's with meta data organized/improved with free mp3tag software.


    I suspect but have no way to prove that onedrive is doing some kind of alias error, for lack of technical term, pointing astiga at where a file used to be.


    thanks for your help

  • gDermgDerm Member

    I sent the link to my entire folder by this artist.

    Something has changed - now only the owl sing a long folder will pay in astiga.

    It was downloaded, the rest were ripped from cd's.

    So, it is in that way at least different.

    But, the files have never had a problem on countless devices for years.

    A few days ago only baby beluga wasn't playing in astiga.

    I changed some file names to remove underscores, and resynced the library. I will send you the import log.

    It looks fine.

  • gravelldgravelld Administrator
    edited November 4

    I downloaded your files and uploaded them again to ensure I had control over them.

    They play ok for me via the Web player. At least, Everything Grows/01 Bathtime.mp3 does.

    Could you try again, and make a note of the time when you try, so I can double check the logs at that particular time?

    Also, have you tried refreshing your access token to OneDrive as per https://community.asti.ga/discussion/comment/1104/#Comment_1104 ? This, though, wouldn't explain why some files work and some don't...

  • gDermgDerm Member

    Hi

    The files are stored on Onedrive which in syned to my PC.

    So I made a backup copy, deleted from onedrive via online portal, emptied one drive recycle bin, and re-uploaded the back up.

    I have not yet re-synced the library because I'm on free edition and I just did a sync recently after removing puncuation from file names.

    So far, no difference. Only the Owl sing a long album plays, the rest say 'file does not seem to conain audio' in the console. But the files are obviously fine.


    I will re-sync tomorrow and send logs and look for date stamp.

    And, I updated the token thing just afew weeks ago when everything stopped working.


    thanks

  • gravelldgravelld Administrator

    Can you make note of the time you attempt to play and let me know?

  • gDermgDerm Member

    currently playing sing able songs album, wouldn't play baby beluga album.


    I have not synced yet.

  • gravelldgravelld Administrator

    I'm going to need the time you tried these things - or was it immediately, to the minute, say, when you posted that message?

  • gDermgDerm Member

    Hi

    It was certainly within 3 minutes.

    As a new experiment I deleted my entire raffi folder and uploaded again, but changed the name of the folder to 'raffii' , to 'i' 's

    I can't help but think the problem is onedrive having its wired crossed some how. In my work i've found databases sometimes really hate to delete things.....so what the heck i'm trying it.

    Its been 3 days so I am re-running the astiga sync rigtht now, which should make 'raffi' go away and replace with 'raffii'


    i will send you the import log when its done.

  • gravelldgravelld Administrator

    How'd it go?

  • gravelldgravelld Administrator

    Oh, just saw your emails.

    When you changed the name of the folder, I have also observed there being a time delay for Astiga to see (or rather: OneDrive to show) the updated names, so I'm not surprised it didn't work immediately.

    Since the last sync, has it been able to play?

  • gDermgDerm Member

    No, no change.

    at 11:25am west coast north america daylight saving time ( a few monutes before this posting) its still not working, the chrome console tells me astiga is looking in a folder called 'raffi' (one 'i') which doesn't exitst, hasn't existed for days, and does not appear in the last sync log which is 3 days old.

    To re-cap

    I made a back up of my 'raffi' folder

    deleted raffi from one drive

    renamed the back up 'raffii' and uploaded back to one drive

    ran astiga sync.

    The sync log makes no mention the folder 'raffi' and does show the folder 'raffii' exactly as expected, but the chrome console says Asitiga is still looking for the raffi folder when it gives error messages when it can't play any raffi songs.


    I"m out of of idea.


    For what's worth, the 'force full refresh' and 'remove files that no longer exist' can't quite work right, because astiga will still play some music which is no longer in the folder it is meant to sync.


    If I could hit a 'delete database' button in Asitga at this point i would, and rebuild it.

  • gravelldgravelld Administrator

    This is weird. I have been able to show the "Raffii" folder correctly - "Raffi" is not shown. I was able to click into "Raffii" and see the albums within. I could play the music.

    It should be upper case "R" btw...

    There is a cache of folders in Astiga, but this only lasts for an hour. I double checked it for your folder but it has been expired.

    Would it be possible to do some screensharing? I'll send you an invite by email.

  • gravelldgravelld Administrator

    Follow up: @gDerm fixed it, most likely, by recreating the OneDrive connection.

    He also re-ripped the CD and re-uploaded it, but I think the first fix was the most likely one to have solved this.

Sign In or Register to comment.