Silent playing on Android 12?

Hi all,

noticed a strange behavior since I use a smartphone with Android 12. I launch an album, first strack plays ok, then the second track plays but silently, no music at all. I must click on "back" to play the track again, and this time it plays ok. Does it everytime! What the heck?

Regards and happy new year!

Greg from Paris

Comments

  • gravelldgravelld Administrator

    Have you tried any other music players? See https://play.asti.ga/apps

  • rdekayrdekay Member

    i have the same issue, pixel 6 pro.

    plays first song on playlist, then plays the next song silently. It actually plays "past" the end of the first song, ie, the song is 3:14 in length, ziggy stardust by david bowie, but it is currently at 5:36 and counting.

    this happens via phone speaker and bluetooth.

    if i forward to the next song it works until the end of that song and then silence in the after time.


    android 12

    astiga version 1.5/10

  • Just for background, I have one tablet device on Android 12 and a phone plus other tablet both currently on 11. All seem to be working okay with Astiga at the moment.

  • gravelldgravelld Administrator

    @rdekay Is this consistent with those songs or all songs?

  • seems like most 2nd songs in a playlist, tried in my car, via blue tooth, the 2nd song "started" but no ,sound.

    if i stop and restart the song it plays fine

  • gravelldgravelld Administrator

    Ok, I've added a ticket. I've marked it as Android 12 only (although from what @Coyley says just having Android 12 doesn't mean the problem is inevitable).

  • gravelldgravelld Administrator

    Oh - what file formats are being used here?

  • GregutiGreguti Member
    edited January 11

    I managed to get rid of this bug, by uncheking the following option:

    Settings -> Playback -> Gapless Playback (if you are seeing strange bugs during playback turning this off may help)

  • gravelldgravelld Administrator

    @rdekay might disabling gapless playback work for you?

    I have tried to replicate this on Android 12 although no luck so far. Gapless Playback is checked for me.

  • Greguti's suggestion solved my issues.


    thanks

    "I managed to get rid of this bug, by uncheking the following option:

    Settings -> Playback -> Gapless Playback (if you are seeing strange bugs during playback turning this off may help)"

  • gravelldgravelld Administrator

    I obviously don't want to have to disable gapless though - but thanks for that data point.

  • gravelldgravelld Administrator

    @rdekay @Greguti If you have the time, are you able to re-create the problem by re-enabling gapless?

    Would it be possible to share two files this occurs with? I'll contact you separately for that, if it's ok.

Sign In or Register to comment.