DNS problems for asti.ga

gravelldgravelld Administrator

It looks like the DNS problems we were encountering back in August/September are back.

(DNS is the method by which domain names like "asti.ga" are converted to IP addresses so that your devices can communicate with Astiga's servers - from the user's point of view it's a bit like the old fashioned way of looking up phone numbers in the telephone directory).

I've had a couple of reports of users in SE Asia and Australia not being able to access astig.ga - that includes the web app, access via the mobile apps and the community site (here).

The problem appears to be that DNS servers in those locations are being refused.

I'm looking into this - if there are any DNS experts out there that can help, I'd be only to happy to chat.


  • gravelldgravelld Administrator

    This appears to be solved now. We increased (massively) the TTL settings on our DNS records and it appears to have fixed the issue. It took 45mins for the changes to appear to take effect, but looking good now.

    If anyone continues to have problems, let us know.

  • I'm not sure if this is related to your Jan 7th issues, but there are again DNS issues.

    For a box I use that uses Amazon's DNS, it works fine. But if I attempt to use Google's DNS, I'm getting SERVFAIL. This behavior has been going on since at least this morning. I know it worked earlier in the week, but I'm not sure exactly when it started failing.

    < plat ~ >> host asti.ga

    asti.ga has address

    asti.ga has IPv6 address 2a01:4f8:c010:520e::1

    asti.ga mail is handled by 10 web0134.zxcs.nl.

    < plat ~ >> host asti.ga

    Using domain server:




    Host asti.ga not found: 2(SERVFAIL)

  • gravelldgravelld Administrator

    Thanks for this. Where are you accessing from? That even looks like it's failing to resolve via Google's name servers? This is an escalation of the problem.

    I'll be looking at migrating DNS to a different provider today.

  • gravelldgravelld Administrator

    Are you currently experiencing any problems @ScionOfEris ? Our health checkers are currently saying they can resolve the IP from anywhere.

  • gravelldgravelld Administrator

    I have started the migration process. It should take about 24 hours I think. Could anyone let me know if they get further issues?

  • It seems fine for me now.

    I'm not sure how long it was going on, but dnschecker.org was showing issues when I posted. I doublechecked at some point on Friday and it was still going on. I'm not sure when it resumed working.

    I tossed a workaround DNS entry into my pihole server, so I haven't had any issues since I first noticed them. I'll pull that out though, so in case this happens again I'll notice.

  • gravelldgravelld Administrator

    Thanks, that would be very helpful.

  • gravelldgravelld Administrator

    Some more reported problems, sadly.

    I've been getting *more* reports of DNS problems for asti.ga, even since the switch to Cloudflare.

    Looks like someone else has the same issue with a .ga domain registered through the same registrar : https://community.cloudflare.com/t/dns-names-have-stopped-to-resolve-on-several-public-dns-servers/368173/3 . Furthermore as @ScionOfEris was reporting, dnschecker is showing some failures: https://dnschecker.org/#A/asti.ga

    Is this affecting anyone else?

  • gravelldgravelld Administrator

    The problem seems to have gone away...

  • gravelldgravelld Administrator

    I received an email from a user who was experiencing this again, and fresh searching found this thread:

    This is an issue on Google's public DNS service (which many people use), however other issues are highlighted which are upstream of Google so could affect anyone, namely that the ultimate registrar for asti.ga, Freenom, got DDoS'd and seem to be susceptible to continued attacks of this kind.

    My knee jerk response is to get the hell of Freenom; the trouble is (1) they are unresponsive to support and (2) our contract lasts until 2030, so it's worrying that they won't handle any kind of transfer correctly and we'll have a load more downtime.


    Kaspersky now flags the web (astiga and community) as suspicius webpages.

    Maybe it´s related....

  • gravelldgravelld Administrator

    At the moment Kaspersky reports "Good" - https://opentip.kaspersky.com/https%3A%2F%2Fasti.ga/?tab=lookup but maybe I'm looking at the wrong thing?

    I've noticed that, sometimes, some of the health watchers flag connection problems as problems during the SSL handshake. This might be related, but whether the underlying issue is DNS lookup I'm not sure.

  • Really sounds extraterrestrial language to me. Sorry. But I received the message on the computer just today. And thought it could be related.

  • gravelldgravelld Administrator

    Thanks for the heads-up!

Sign In or Register to comment.