Unable to update library from google drive

so5so5 Member

I received a lot of error like the below when I tried to sync with google drive. Any help?

2022-02-12T15:11:08 ERROR  This file does not appear to be an audio file
2022-02-12T15:11:17 F_ERR  {
 "error": {
  "errors": [
   {
    "domain": "global",
    "reason": "notFound",
    "message": "File not found: .",
    "locationType": "parameter",
    "location": "fileId"
   }
  ],
  "code": 404,
  "message": "File not found: ."


Comments

  • so5so5 Member

    Just to add, I can play all files directly rom google drive.

  • gravelldgravelld Administrator

    It looks like the underlying problem is "File not found".

    I'm seeing a few error messages about the connection to the storage. Have you tried re-creating the token and updating the storage?

    1. Click the pencil next to the storage name
    2. Click _Get token_ and go through the validation process in Google Drive
    3. Copy/paste the token back into Astiga and click _Save storage_.

    In addition I've added some extra logging so I know which files are actually failing to lookup.

  • so5so5 Member

    Thanks. I did update the token but it doesnt work. Astiga failed to lookup all files in my Google Drive.

  • gravelldgravelld Administrator

    Thanks for trying that. I'll see if I can walk through the steps tomorrow.

  • gravelldgravelld Administrator
    edited February 15

    @so5 This looks like it's working now. Can you confirm?

Sign In or Register to comment.