playlist file format

Struggling to understand playlists. I can create them on Web App or Android App, and play them. But I want to import playlists using Web App Library|Import Playlists function. My file imported OK (it appears under Playlists), but when I try to play it in Android app it says 'Waiting for WiFi or local non-roaming network)'. WiFi network is OK, I can play all other Astiga-app created playlists. It occurs to me the format of the M3U I created is incorrect.

My collection is single storage (pCloud), the root folder is My Music\. It is organized in the common folder/file schema of ArtistName\AlbumName\TrackName. I tried listing each track in the playlist file with and without the 'My Music' parent path (e.g., My Music\Artist\Album\trackfile and also Artist\Album\trackfile), but cannot get it to work.

Perhaps I need to use Unix path delimiters (Artist/Album/track)? Something else?

I can see working playlists (created within the app) listed, but cannot download/view/edit them. If it were possible to view the app-created playlists, I could use that as a template. Perhaps someone could point me to an example M3U (or PLS) playlist file than will play when imported into Astiga.

Thanks

Comments

  • gravelldgravelld Administrator

    Does https://community.asti.ga/discussion/comment/1339/#Comment_1339 help?

    Can you copy/paste a section of your playlist?

    It shouldn't be required to use forward slashes - we should convert backslashes in the Astiga code. They need to be relative paths though, as per above.

  • cmartincmartin Member

    I read that discussion from January, I understand about the relative path issue, but still unsure why is doesn't work. My pCloud initial folder is 'My Music'.

    I am able to access my pCloud storage as a mapped drive (p:) from Windows. Here is the output of the DOS DIR cmd for those 2 directories:

     Directory of P:\My Music\Patty Larkin\ANgels running

    01/24/2022 08:13 AM    27,988,035 02 - Do Not Disturb.flac

    01/24/2022 08:14 AM    24,896,497 07 - Helen.flac

     Directory of P:\My Music\David Surette\Back Roads

    02/10/2022 11:19 AM    22,489,787 04 - Andakten.flac

    02/10/2022 11:19 AM    23,417,902 12 - Speed the Plough.flac


    There are actually additional tracks in each of these folders, but I am just showing the 4 tracks I put in the playlist.

    Here is the contents of the playlist file:

    Patty Larkin\Angels Running\02 - Do Not Disturb.flac

    David Surette\Back Roads\04 - Andakten.flac

    Patty Larkin\Angels Running\07 - Helen.flac

    David Surette\Back Roads\12 - Speed the Plough.flac


    I saved the playlist in p:\My Music\Amiga_test_playlist.m3u.

    I import the playlist in Web App, and when I click on it in Android, it shows the 4 file names but won't play anything. When I try to play the tracks, the top of screen says "Now Playing" and "Playing 1/4", but at the bottom it says "Waiting for Wifi or local (non-roaming) netw...". (screeenshot here https://ibb.co/Tm1N4p5 ). I can click to move to next/prev files, and it changes the filename, but none of them will play.

    Also, I am able to play these tracks directly from Library or Browser, so I know the files are OK. I have another playlist called "PattyL_test" which I created from within the app. It contains all the tracks on that album. If you are able to access that playlist, you might compare what is shown for these 2 tracks in that file versus my imported playlist file, since when I click on the PattyL_test playlist, these songs play just fine.

    Could it have any thing to do with track numbers? As you can see in file listing above, track numbers are part of my filenames (XX - TrackName.flac), but I noticed that when I click on the imported playlist, it lists the 4 files stripped of track numbers, it just shows the track names on screen as:

    Do Not Disburb.flac

    Andakten.flac

    Helen.flac

    Speed the Plough.flac

     However, when I click on the PattyL_test playlist (generated by the app), it shows these two track names with track nos., like the filenames:

    02 - Do Not Disburb.flac

    07 - Helen.flac

    Not sure what that is about. Just for fun, I also imported a version of the playlist without track numbers (even though the actual filenames include them); no difference, they still won't play, gives "Waiting for wifi..." error.

    Another wrinkle. While testing this past few hours, I use web app to import the playlist, and then try to play from Android app, also tried to play a few times on the web app. Earlier today, I couldn't get the tracks to play on either platform; just now they are playing in webapp but not in Android app.

    Thanks

  • gravelldgravelld Administrator

    Hmmm. This is working for me right now. I have tried with backslashes, folders with spaces, FLAC files... they all work. In the Web app and on the Android device.

    I think I'm going to have to try to replicate your entire setup and see what happens on the server when we press play. Sorry - I ran out of time today to do this.

  • gravelldgravelld Administrator

    I copied your playlists and it appears to work for me, this is really puzzling.

    Would it be possible to arrange some screensharing to see what happens on your browser when you try to play? We should do this privately, obviously.

Sign In or Register to comment.