Google Drive Error

neasanneasan Member

I can't seem to play anything off my Google drive (both web and android app).

When I go to the file browser (on the web) I get:

{"error": {"errors": [{"domain": "global", "reason": "notFound", "message": "File not found: .", "locationType": "parameter", "location": "fileId"}],"code": 404,"message": "File not found: ."}}

Looking at the browser on the Andorid app just says "No data"

Is this on my end I did try to reauthenticate my google drive but go the same error as above but with the added info "Google Drive could not be added/edited, please check the entered settings and try again"

Comments

  • gravelldgravelld Administrator

    For the record, I can play things from Google Drive currently.

    It's a bit difficult to see in the log files what might be causing this because there's no correlation data for your user ID. Can you remember the time you attempted this?

    I can see a sync was last run on Sunday and that appeared to complete ok.

    "File not found: ."
    

    This looks like a blank path - or a reference to the current folder, which seems weird. I can't see any such string in your library.

    Is the initial folder still valid?

    Once you re-authenticated, you did copy and paste the new token didn't you?

    Can you send a screenshot of the error message?

  • neasanneasan Member
    edited May 17

    I tried it just after 9am (BST) this morning, around when I posted.

    I did paste the new token in.

    I have done some playing around.

    Currently my music sits at "/Music/Neasan/Astiga" however "Astiga" is a shortcut to "/Computers/My Mac Book Pro/Music/Astiga". This is outlined in the section about attaching a Gdrive "To add shared folders to Astiga, add a shortcut from that folder to My Drive."

    When I changed Astiga to point to just "/Music/Neasan" it added the drive but it does not see "Astiga" as a subfolder

    When I tried to change it back to "/Music/Neasan/Astiga" I get the error (I have sent a screenshot to info@asti.ga)

    GDrive does now have a new warning "Over the coming weeks, items in more than one folder will be replaced by shortcuts. Access to files and folders won't change.", which might be related?

  • neasanneasan Member
    edited May 17

    OK I think I fixed it by going "Advanced" in the Google Drive settings for Astiga and resetting the root to "/Computers/My Mac Book Pro/Music/" and then pointing the initial folder to "/Astiga"

    I can use the file browser to play music but think I need to do a full re-sync for the rest to work.

    Once I have confirmed that works will need to do it with my wife's account as we were setup in the same way 😂

    EDIT: And rebuild my playlists

  • gravelldgravelld Administrator

    Thanks for your investigative work.

    So is it the shortcut that wasn't working for you?

  • neasanneasan Member

    That seemed to be the issue.

    I am streaming by accessing the files directly and will wait till I get the email telling me the sync has finished before trying the "normal" way

  • neasanneasan Member
    edited May 17

    Just an update, this does not appeared to have fixed the issue.

    I can play songs by browsing for the files.

    However when I click play on an album/song in the library/normal way it loads it to the playlist/queue but on mobile it doesn't download anything and in the web version (Firefox on macOS) it just does that loading thing above the play bar for a few seconds and then stops.

    The sync completed and according to the log it appeared to "GET" and "ADD" all my files (I forced a refresh) except for a few errors (138 fails, which I need to investigate as a spot check lets me play those files from the storage).

    Post edited by neasan on
  • gravelldgravelld Administrator

    In your library the paths are still listed as Music/Neasan/Astiga/ - didn't you need to change that to Computers/My Mac Book Pro/Music/Astiga?

  • neasanneasan Member
    edited May 18

    I followed the experimental settings:

    Root folder (experimental)

    Do not change this setting unless you know what you are doing!

    This is the folder from where all paths will be determined. Only use this when your files are not reachable from the My Drive folder (e.g. when using My Computers).

    Enter the ID for the folder you want to start in. The ID is the part that comes after "folders/" in the URL,

     e.g.: https://drive.google.com/drive/u/0/folders/xxxxxxxxxxxxxxxxxxxxxxx.

    When in doubt, keep it as "root".

    So I changed "root" to *string of numbers*

    This fixed playing the files directly, which was not working originally and the logs seem to be pointing to the correct location e.g. "Astiga/3 Inches of Blood" not "Music/Neasan/Astiga/3 Inches of Blood", which I think it used to say.

    So it appears Astiga knows where the files but post sync it has not updated my library, can I flush the library and start again somehow?

  • gravelldgravelld Administrator

    Erm, _Force refresh everything_ should do that... I can clean it out manually if you like. Or you could remove the storage and re-add it?

    Or you could remove the folder - https://play.asti.ga/remove-library

  • neasanneasan Member

    I have removed the storage and re-added it, again I can play the files directly so have set a sync running, fingers crossed it works 😂

  • gravelldgravelld Administrator

    Let me know!

  • neasanneasan Member

    Works now, lost all my "Data" (Most Played and Recently Played) and it broke my playlists but everything else seems fine.

    69 failed as not being music files so will check on them

  • gravelldgravelld Administrator

    Gah! You know - if it was just a simple prefix path swap I could've done that for you and retained your data - sorry for only saying that now.

    Pleased it works though!

  • Zinger393Zinger393 Member
    edited May 24

    I am experiencing a simmilar issue. Im not sure if i did the exact same steps but i get this error when trying to sync

    { "error": { "errors": [ { "domain": "global", "reason": "notFound", "message": "File not found: .", "locationType": "parameter", "location": "fileId" } ], "code": 404, "message": "File not found: ." } }

    My inital folder is /Music and it is also a shortcut. The folder is shared with another account and the other one, which owns the files. Works without issue. I also tried to set the intial folder and the root using the advanced settings.


    I was able to get the sync to work at first by adding the folder ID under advanced settings but now it wont sync at all. Before I removed the sync all my files started showing 0:00 time stamps


    I would like to get premium but we wont be if we cant get the software to work.

  • gravelldgravelld Administrator

    Thanks for reporting @Zinger393 .

    I just stepped through the sharing process to test for myself, in case something has broken.

    1. First I shared a music folder from my personal Google account with my work Google account. I was set as "Editor" (not sure if this affects things).
    2. On my work account I then checked the folder appeared under _Shared with me_. It did.
    3. In Astiga, I added a new Google Drive storage and set:
    1. I added the token and saved.

    I could play and sync from this point.

    Are there any steps in the above list that are divergent from what you are doing/experiencing? (Apart from the last one of course!)

    If the folder is called "Music" then I don't think that should be the initial folder - you should use the ID for "Music" and then have "My Music" (which is the subfolder currently) as your initial folder.

  • Zinger393Zinger393 Member
    edited May 24

    If i do that, this is what happens. I get the following error


    Google Drive could not be added/edited, please check the entered settings and try again

    { "error": { "errors": [ { "domain": "global", "reason": "notFound", "message": "File not found: .", "locationType": "parameter", "location": "fileId" } ], "code": 404, "message": "File not found: ." } }


    The screenshot shows how i have it set up

  • Zinger393Zinger393 Member

    Heres what it looks like with the error


  • Zinger393Zinger393 Member

    If i get the information from the account that the folder is shared from, and sync the folder directly, it works without issue.

  • gravelldgravelld Administrator

    Thanks for the descriptions and taking the time to post the screenies.

    When you copy/paste the folder ID for the "Root folder" field, what folder is shown in Google Drive?

    If it's the Music folder, I think this might be wrong because your initial folder is then looking for a Music folder inside Music itself.

    If that's the case, can you try changing the initial folder? Try:

    My Music
    /My Music
    

    Just trying to eliminate possibilities...

  • Zinger393Zinger393 Member

    understood. I resynced the directory from the account its shared from and everything is working correctly.

  • gravelldgravelld Administrator

    Excellent! 😀

Sign In or Register to comment.