performance issues

Lately I've been having quite a few (performance) issues with the web player. I guess it's been week if not months, some moments being bad while others it works fine. Issues on different systems and browsers.

Issues include the following:

  • Pages take long to load.
  • Images take long to load.
  • Tracks take long to add to playlist.
  • When tracks take long at add, they sometimes get added in a different order than selected.
  • Changes to the current playlist are not saved/remembered causing it to remove the tracks at page refresh (and sometimes page changes), sometimes only the later part is not remembered.
  • Tracks sometimes seem to buffer long, causing long breaks between songs.

I'm guessing most this issues have to do with server load or caching issues. Since it's on multiple systems and different browsers I'm guessing it's on your side. It's kinda obstructive when it appears, which is sad as when it works smooth, Astiga works great.

Comments

  • gravelldgravelld Administrator

    We're just about to announce a new release which we hope has fixed this, to an extent. I think in some cases we were making too many requests when populating the play queue - it was probably a regression introduced with the new design.

    Let me know if things stay the same. Make sure you have reloading your pages from cache!

  • It seems to be fixed now indeed! If only I waited a day before reporting lol

  • gravelldgravelld Administrator

    :phew:

  • Changes to the current playlist are not saved/remembered causing it to remove the tracks at page refresh (and sometimes page changes), sometimes only the later part is not remembered.

    This one still seems to exist. Whenever I move songs in the playlist, as soon as the next song starts is just resets.

    Today it even happened that I added a song, then another, played the first added song, moved that one up, then moved the 2nd added song right below that, and after it finished it started playing the song below where I moved the 1st added song but the 1st added song was reset to the bottom again with with 2nd added song right below it.

    Basically I can only properly make playlists on phone now, as PC can only add more songs to the bottom since everything else just resets as soon as the next song is up...

  • gravelldgravelld Administrator

    Thanks for highlighting this - I'll add a ticket.

    What do you mean by:

    I added a song, then another, played the first added song, moved that one up, then moved the 2nd added song right below that

    ?

    If you played the first added song, I thought that would already be at the top. So are you referring to an existing play queue that is already populated?

  • CambionnCambionn Member
    edited January 3

    Yes! I had an existing que than added the songs.

    In general moving anything resets after next song, but that specific case was extra weird as it shows it half understood I changed positions as it was playing the song I moved it above to despite moving it back down.

    Post edited by Cambionn on
  • gravelldgravelld Administrator

    Thanks, I've added a ticket and we'll try to replicate and fix.

Sign In or Register to comment.