Wrong User Name or Password Over and Over On Mobile App

DrystDryst Member

I keep making sure my email address and password are correct. After I change it then test connection, everything from the mobile app works briefly. Later I again get wrong user name or password. This is making the mobile app unusable.


  • gravelldgravelld Administrator

    This sounds really odd - I've not seen this. Could it be a bad connection? I guess not - you'd have suggested that...

  • DrystDryst Member
    edited March 28

    This is my home Internet connection. It is broadband. My mobile phone is using wifi to my router. This is my computer I am posting from using that same connection. The connection is fast and stable. The mobile app does not work at all and continues to have issues.

    I can get it to work temporarily by removing my account under settings then re-adding it. What was happening yesterday was minutes later I would again see wrong password.

    Could it be the server is getting attacked?

  • It works perfect for me. Web and Official App. Not a server problem.

    Delete app data. And open again.

  • DrystDryst Member
    edited March 28

    Now the mobile app does not like my password. I did enable two factor authentication on Astiga to prevent hack attempts.

    Logging into the website works without issue, so I have been playing media content from my mobile phone from the website. The mobile app is not working for me at all.

  • DrystDryst Member

    The reason I posted that I had just purchased premium is that all these issues started right after paying

  • DrystDryst Member

    I had completely uninstalled the app, followed by reinstalling several times. I will need more information on what data to delete.

  • DrystDryst Member

    okay -- the mobile app does not like two-factor authentication. It wants me to use a token. There is no entry for it. I had enabled two-factor authentication yesterday.

  • DrystDryst Member

    There is an entry for user name then password only.

    What is the expectation for the two-factor authentication token? Enter it before or after password?

  • neasanneasan Member

    I just enabled 2FA to check this.

    I was logged out of the web app and had to login with username, password and code, no problem.

    I then removed my account from the android app and added it again with my username and password and when I test the connection or try to play music it brings up "Wrong username or password".

    Before doing anything else I disabled 2FA on the web app and clicked test the connection again on the app and it worked.

    At no point was I asked for a 2FA key when logging into the app or am I missing something?

  • gravelldgravelld Administrator

    Have you tried using the token here:

    Hover over the token and double click to copy/paste.

    Use that in place of the password... does that work?

  • DrystDryst Member
    edited March 29

    The web app works no problem using two factor authentication. I am not complaining about the web app at all.

    The mobile app has zero entries for token. My installed mobile app has user name and password entries only. Is this screenshot above for the mobile app? This is what I am complaining about.

    I tried pasting the token into the password entry, and it is not accepted.

  • gravelldgravelld Administrator
    edited March 29

    As per this thread...

    1. Enable 2FA, use the QR code to add an entry to your authenticator app (e.g. Google Authenticator). You'll be logged out once this is completed.
    2. Log back in again, using your authenticator app to generate a code as well as providing your "normal" Astiga password.

    That should prove 2FA with the web app works...

    Next, to configure the Android app...

    1. Hamburger -> Settings -> Accounts -> Astiga -> Password
    2. In the popup, copy and paste or copy the token on the https://play.asti.ga/apps page. This is 20 characters long, case sensitive and watch out for 0/O .

    If you ok that, and test connection, it should work. It does for me...

    So, another way of looking at it is that you don't really have true 2FA in the app. You simply swap your Astiga password for the Subsonic one on the apps page.

  • DrystDryst Member

    #1 and #2 at the top were done two days ago. I can successfully login to the web app no problem using my Authenticator Pro mobile app. It generates codes that I enter into the web application, and I can login successfully. That long setup key was not used for Authenticator Pro. I simply scanned the QR code when I setup 2FA.

    For the setup the mobile app steps, I do not have a 20 character long token at all. I have six digits that are generated from Authenticator Pro.

  • gravelldgravelld Administrator

    The token is in the Astiga web app at this URL: https://play.asti.ga/apps

    You have to hover over it to reveal it.

    Can you confirm you can see that?

  • DrystDryst Member

    Yes. I do see a token there. Entering that in allowed me to login. This was very bizarre. There is not even an option to copy that text after revealing it.

  • DrystDryst Member

    Consider that I will be in my car trying to enter this to play music. Can the same login that is being done for the main website also be used for the mobile app? I realize that this code may have been created by others, but this is really odd.

  • gravelldgravelld Administrator
    edited March 29

    You only need to enter it once...

    While I can agree this is slightly head scratching, the reason it's required is that it's a way of allowing any Subsonic app connect to Astiga, so you can also choose Symfonium, Ultrasonic etc etc.

Sign In or Register to comment.