Odd streaming issue

kalowskikalowski Member

Here's an odd one.

I am streaming the astiga app to my Google home via Bluetooth.

After each song I get silence. I check and astiga is playing the song it claims.

I click on back so the song starts again and this time it plays. Done if for every song on my (permanently) cached playlist.


  • gravelldgravelld Administrator

    So you're using the Astiga mobile app to control playback, correct?

    Does forward work as well - i.e. it moves onto the next track and plays?

    Can you let me know the times you're testing this so I can look in the logs?

  • Yes. Moving in any way forward or back.

  • gravelldgravelld Administrator

    Ok - if it's still happening, please let me know the times you've tried this, ideally to the minute (with timezone).

  • Well of course it's not happened once today! But will let you know if it does or if it's somehow sorted itself.

  • It just happened

    At 17:21 BST the next queued track was playing but no sound. Hit back and it started.

  • Then played the next song but then did it again at 1732.

  • gravelldgravelld Administrator

    Around that time there were some error messages about decoding 24 bit files, which might be an indication of server load, but nothing related to your files. Is this continuing?

  • Yes. Happened again yesterday. I wonder if it is something to do with the device and not Astiga.

  • gravelldgravelld Administrator

    It's possible. Do you ever encounter it when not using Bluetooth or the Google Home?

  • No. Nowhere else.

  • gravelldgravelld Administrator

    I think that might isolate the problem a bit then. Which is annoying.

    Have you tried with other Bluetooth devices?

  • No, but I have some Bluetooth headphones which I will try with at some point.

  • OK. So this afternoon I was connected to this player by Bluetooth and had no issues. But I've just gone out and used my Bluetooth headphones and had the same issue. Circa 19:16-19:17 and literally just now 19:19.

  • gravelldgravelld Administrator

    That's helpful. Bluetooth is a consistent factor in the problem, although it's by no means a conclusive cause.

    Would you say this describes the issue? https://github.com/daneren2005/Subsonic/issues/1081 (this is the issue tracker for the app that the Astiga app is based on).

  • Yes, very much so

  • gravelldgravelld Administrator

    What is your device? And Android version? Should be Settings -> About Phone or similar.

    The consistent thing on that issue is Pixel 6 phones. This is also related: https://github.com/daneren2005/Subsonic/issues/1122 and suggests unchecking gapless playback as a workaround.

Sign In or Register to comment.