Tempo app support

So I finally found a FOSS player that does all I want. It has library search, saving local, and a nice fancy interface.

The problem is, when I login with my Astiga account, it shows all my tracks and library correctly, but none of the image show and no track play. Other subsonic players work just fine in the past, but it's been a while. They never stuck because I missed features.

Could you perhaps check Astiga compatibility with this one? Especially since subsonic clients should work, and the files and metadata gets found but sonehow it can't actually play them.


  • gravelldgravelld Administrator

    I did already test this one and it appeared to work (that's album art under "Discovery"): https://twitter.com/astigamusic/status/1673717069861322752

    ... but it was six weeks ago so maybe something changed. I'll try to check it next week.

  • Would be cool! It's stuck like this now:

  • Any updates? The app had an update today but the issue still persists.

  • gravelldgravelld Administrator

    No, I haven't had the chance to test it myself yet.

  • gravelldgravelld Administrator

    Working fine for me on v3.5.0 - what version are you on?

    I installed it directly from the APK rather than via F-Droid.

  • Just a question. The transcoding option of the app, it´s allowed on Astiga? It says "This feature requires support from your Subsonic server."

  • gravelldgravelld Administrator

    I think this relates to Server Side Transcoding. It looks like this was implemented by, if this option is checked, not sending user preferences about the max bit rate and format. In fact, Astiga ignores these anyway, and continues to transcode as it sees fit. So I think the answer is yes, it's supported, but only kind-of because we don't support the client side transcoding options.

  • 👍 ok Thanks!

  • I'm on 3.5.0 as well. I tried with the Low Security option on and off but both end the same.

    Clearly, it's getting in enough to see some metadata, but not actually play the files or grab images.

    Just thinking here:

    • Since it's using the token I would expect MFA to be unrelated.
    • I'm guessing the metadata shown might be from Astiga's sync, but the files themselves can't be reached somehow?
      • Could it maybe have to do with the type of storage? As in WebDav vs something else?

  • gravelldgravelld Administrator

    Maybe - let me try to think about it tomorrow.

  • gravelldgravelld Administrator

    I think I've worked it out. Tempo isn't properly encoding the "+" suffix in your email address when passing it to Astiga, as a result you aren't authenticated and nothing is returned. This only seems to affect the /getCoverArt (and presumably /stream ) calls.

    I created an issue on Tempo here: https://github.com/CappielloAntonio/tempo/issues/41 .

  • I noticed the git issue. I don't know if it's useful for you to know, but I also tried the 3.5.1 but I get the same crashing issue you described in the issue. Not sure how to get the crash logs he asked for tho.

  • gravelldgravelld Administrator

    Thanks, I'll be trying to get some logs for him later.

  • gravelldgravelld Administrator

    Looks like 3.5.3 fixes this 🙂

  • Yes it works now! Thank you so much, time to test the app in-use 😃.

    Hope you don't mind me leaving the official one for now. Part of it is trying to go all FOSS, part of it is the app looking fancy while still having library search and other functions I was really missing in other non-official apps.

  • gravelldgravelld Administrator

    No, it's fine, part of the flexibility of Astiga is using your own app...

Sign In or Register to comment.