Rating Failure For Android App

DrystDryst Member

It appears this app was recently updated to a newer version. When I attempted to click thumbs up for songs played, I see the following error:


  • gravelldgravelld Administrator

    Interesting - can you confirm your app version and your Android version?

  • DrystDryst Member
    edited September 18

    I can find no way to show the version of the moble app. I am clicking every option under the launched app's Settings to not find a way to display the version.

    My phone runs Android 13.

  • DrystDryst Member
    edited September 18

    I just found it looking under Android settings: 1.5.21

    It looks like this is a BETA version. I do not recall every signing up for Google Play store BETA testing.

  • gravelldgravelld Administrator

    You should be able to leave it by going to the Play Store page for Astiga - but it won't help here because it's the same version as that which is under general availability.

    I'll take a look!

  • gravelldgravelld Administrator

    The problem is that we'd recently made a change to expose all errors that occur when setting ratings.

    Before, this would've been swallowed and you wouldn't have known the rating wasn't set.

    Now an error is returned, but the error wasn't compliant with the app. I've fixed this on the server, so can you try setting the rating again?

    It will fail again, but it should show a better error message (I noticed you'll have to be quick to take a screenshot though).

  • Here is the new error message. This is not overly helpful:

    This issue was introduced with this update. I was previously able to use thumbs up that worked without issue with the older version. Star does work without issue.

  • gravelldgravelld Administrator

    Yep - it's a bug still in the same area. Can you try again now?

  • It works now. Thank you.

  • gravelldgravelld Administrator

    Thanks for confirming!

Sign In or Register to comment.