"Astiga cannot function without the ability to write to storage"


I reinstalled the Astiga Android app today and I'm receiving the error message in the subject when I try to launch the app. The app doesn't ask for this permission, despite it noting that it will on the store. It doesn't appear in the permissions list for files and media. I reinstalled the app, restarted the phone, cleared cache and data.

Samsung Galaxy Flip Z3

Android 13

app ver. 1.5.21


  • gravelldgravelld Administrator

    Hi - there's a fix for this in alpha at the moment, but Google are doing their usual trick of not allowing promotion because of some arbitrary-issue-they-won't-tell-me-about.

    The problem (as far as tested and fixed so far) relates to phones on Android 13 with no external SD card.

    I can send you a link to the alpha if you like? Google just aren't allowing it to be pushed through the Play Store right now.

  • Hello,

    I have exactly the same error.

    Could I perhaps also have the link sent to me? Thank you in advance.

  • gravelldgravelld Administrator

    @ChristianReims I can add you to the alpha list (probably the easiest way) but I'll need the email address you have on Google Play. Your Astiga email address doesn't work. You could send it to me via info@asti.ga ...

  • I have exactly the same error. Help

  • Did you manage to solve the problem?

  • Hi, I have the same error but I do have an external sd card.

  • gravelldgravelld Administrator

    The problem has been solved for about two weeks, but Google are blocking its release without telling us why. Well, they are telling us why, but the description is so useless we're reduced to guessing what might fix it, attempting a new release, being refused... and so on, repeated. It's extremely frustrating (if anyone has any insight into Google Play's review policy process that might be able to provide more detail, please let me know!)

    I have a URL from which you can download the fix and install it directly: https://drive.google.com/file/d/1E8jL9nS2uih2RsQ-O-6R2t47FJhuKB7g/view

    Alternatively, I can add you to the alpha list (for some reason it was fine to release to alpha). Please send your Google Play email address to info@asti.ga and I'll add you.

  • Hi. Have installed the apk from the URL, now it works, without the problem about storage.... but it doesn´t work with android auto. Doesn´t appears on the list of apps to connect.

  • gravelldgravelld Administrator

    Hmmm - yes, this might be related to not being distributed through the Play Store.

    I'm afraid Google are still refusing to publish. Their latest reason? "App doesn't perform as expected". Well jeez... thanks for the explanation.

  • Ok. Knowing that... I've turned on the development options for Android auto. And activated the "unknown sources". Now it works...


  • gravelldgravelld Administrator

    Thanks for letting me know about the workaround, and apologies for the inconvenience...

Sign In or Register to comment.