Only adding first song of album to playlist

Hello - When I go to the Albums view and click on the play (arrow) button that appears when hovering over an individual album, it only loads the first song of the album onto the playlist, whereas it used to just load the whole album. If I click on the individual album cover and enter the single-album view and then click on the play button, it will then load the full album like it used to. This seems like a new bug, not sure if anyone else is experiencing this.


  • gravelldgravelld Administrator

    Web app or Android app? Which page are you on when this happens? (Copy and paste the URL).

    Can you say which album, in your case?

    Could you refresh the page to make sure you have the latest Javascript?

    I just tried at and it works for me...

  • ruffinruffin Member
    edited November 2023

    I tried to add Hackney Diamonds from the album view (albums, h, click box) to a stones playlist twice. Both times I only got the first song added. The tracks are AAC if that means anything.

    Also, related, is there a way to remove a song or songs from a playlist? I could find move, but not remove.

    Let's see.. I'll answer the questions we've got above:

    • This is on the web UI.
    • Astiga for album, - Astiga for playlist.
    • Did control-F5, tried again, I now have three copies of Angry in my playlist and no other songs added.

  • gravelldgravelld Administrator
    edited November 2023

    Also, @tongnamu or @ruffin - can you confirm you're talking about the play queue, not a saved playlist?

    @ruffin What page are you on, and are you clicking "+" or the play icon? I'm not sure what you mean by _click box_.

  • ruffinruffin Member
    edited November 2023

    Now trying to add the album to the Now Playing queue from

    is only adding the first song to the queue. So not just playlists.

    Added them all if I went to the album page and clicked add "all" from the album cover.
  • tongnamutongnamu Member
    edited November 2023

    Sorry! I'm on the web app (I tried it on both Firefox and Chrome), and yes I am referring to the play queue, and it happens with every album I try, and refreshing the page doesn't fix it.

    It happens when I am on or - Those are both pages in which it displays album covers. If you hover over the album cover the play button appears, and that's what I'm talking about - it only loads the first track onto the queue. If I click on the album cover itself (so it shows me the full track list for the album, as in e.g. and I click on the play button there, it will then add the entire track list.

  • gravelldgravelld Administrator

    Oh, ok. Gotcha - I see the same thing on the /albums/ page. I was on the specific album page before.

    I'll look into this now.

  • gravelldgravelld Administrator

    Should be fixed - you'll need to perform a hard refresh on the page to get the latest Javascript.

    Thanks for reporting - let me know it works for you both @tongnamu @ruffin 👍️

  • Adding the album to a playlist from just worked.

    Now how do I delete the dupes from the playlist? Still can't figure that out... :thinking:

  • gravelldgravelld Administrator
    edited November 2023

    Hmmm. You could load them into the play queue, delete, then save. We need to implement delete obviously!

    If that doesn't work, send me an email with all the songs you want deleted and I can do it in the db.

  • Just tried it out and it works great now! Thank you!

  • gravelldgravelld Administrator


Sign In or Register to comment.