Trouble adding a specific NextCloud

Hey there. I'm trying to add a NextCloud instance that exists at over WebDAV. I don't control the instance, but I do have an account there. The configuration suggested when logged in there looks exactly the same as the NextCloud preset template.

Base URL:

Initial folder: /remote.php/dav/files/MY_USERNAME/Astiga

But when I try to save the configuration or browse the files within I get an error, but the error is blank. "Loading... | An error occured: | Go back to the initial directory" Likewise, trying to edit the nonworking configuration I have saved gives me this error: "WebDAV could not be added/edited, please check the entered settings and try again" I tried connecting to it via a regular WebDAV client and it connects without any problems. I initially had 2FA enabled on the account and was using an app password to connect Astiga, but when that didn't work I turned off 2FA and tried using the account password instead. Same result.

Any help would be appreciated. 😀


  • gravelldgravelld Administrator

    What are the connection settings you have in your regular WebDAV client?

  • Here's what works in Cyberduck over WebDAV (HTTPS):


    Port: 443

    Path: /remote.php/dav/files/MY_USERNAME/Astiga

    I didn't specify anything else and it works. Their certificate is good, too.

  • gravelldgravelld Administrator

    Erm... are you sure it's not working? There are logs suggesting it is - can you browse via[account name] ?

    Is there one specific page where it doesn't work?

  • I'm still not able to do it. I now have it set to the root of my account's storage. Within there is only the Astiga folder, and there's a subfolder containing a single album's worth of songs. I still get the same error when trying to browse at[account name]. I did however, try to sync it just now, and the plaintext contents of the sync log looked like it contained an html file.

    The folder '/remote.php/dav/files/[MY_USERNAME]' could not be synced because an error occurred. Check whether your storage settings are correct. Error details: <!DOCTYPE html><html lang="en-US"><head><title>Just a moment...</title><meta http-equiv="Content-Type" content="text/html; charset=UTF-8"><meta http-equiv="X-UA-Compatible" content="IE=Edge"><meta name="robots" content="noindex,nofollow"><meta name="viewport" content="

    It just goes on and on until it finally hits </script></body></html>

    I also got an email from the provider noting a new login from around the time of your reply. I hadn't previously gotten an email like this when I was trying to add the provider earlier.

  • gravelldgravelld Administrator

    That email is me trying to push some buttons.

    To debug this, we're going to have to take it offline because it will require you giving me access to the account in cynthialabs.

  • I removed the cloud from Astiga on my end and sent Astiga support an email. :)

  • gravelldgravelld Administrator

    Thanks 👍️

Sign In or Register to comment.