Computer root not showing

KlowKlow Member
edited June 20 in Bugs


The app through Google Drive only shows my Google Maps folder, not my computer. Am I missing something?

Thanks for your help!


  • gravelldgravelld Administrator

    Can you describe what you mean by "The app through Google Drive only shows my Google Maps folder"?

    Are you using the Android or Web app?

    Which page are you seeing this on?

  • KlowKlow Member
    edited June 20

    Sorry if it wasn't very clear (not my native language). I'm referring to the Android app.

    So, typically in the Google Drive root you can choose 2 tabs: "My Drive", which contains things only in the cloud, including (in my case) customs Google maps from Google Earth or Google My Maps, or any other file I want to put there. The other tab is "Computers", i.e. any physical computer with their contents shared in Google Drive. This is where my music is, but for some reason Astiga only shows "My Drive" and not "Computers". I hope this clarifies things a bit.

  • gravelldgravelld Administrator

    Ok - the /Computers link you see in Google Drive isn't connectable to Astiga. That's because it's simply not a feature of the connection provided by Google - see this page for a feature request for Google to add this.

    Instead you need to update or recreate your connection to Google, specifying the folder ID as the "Root folder". Here's how:

    On the Google Drive settings you can enter anything for the name. The Token is populated by Google after you authorise the connection - if you're editing an existing connection leave that unchanged. The Initial folder refers to the initial folder Astiga starts from inside your shared "Computers" folder so maybe leave that alone too:

    The important bit: Click Advanced settings:

    For the Root folder, go to Google Drive and enter the folder you want Astiga to connect to:

    Copy the string following .../folders/ - in this case it's everything from 1-4WXCC... .

    Paste that into Root folder as I did above.

    Then save the storage and try browsing:

    Let me know how you got on.

  • KlowKlow Member

    Thank you for this very thorough explanation. However upon pasting the string into the root field, it still doesn't show my folder.

  • gravelldgravelld Administrator

    To protect your privacy, could you email us at with some screenshots of your Google Drive showing the Computers and folders you're trying to show?

  • KlowKlow Member

    Sure. I sent you a couple pictures.

  • gravelldgravelld Administrator

    Turns out (we think) the initial "/" folder was cached and our cache doesn't take into account the change to the "root folder" setting, thus it was serving the original folder contents without the root folder taken into account. With the cache cleared it works.

  • KlowKlow Member

    Indeed it works now. Many thanks.

Sign In or Register to comment.