Support SubSonic API's playlist sync

I know the official Astiga app has sync between phone and web-app. However this has never worked properly for me, as the web-app to phone is supposed to show a pop-up which I only gotten in the far passed and never been able to get back (there is an old topic about that). A few days ago I noticed in the Tempo app that is has the following option:

This leads me to believe that within SubSonic, there is an option to sync library. Since turning the option on doesn't work with Astiga, I'm assuming Astiga doesn't support it. Since the implementation of Astiga is buggy anyways, and only works phone to web-app to me but not the other way around, I'm thinking it might be a nice solution to implement the SubSonic implementation into Astiga. This gives increased compatibility with SubSonic apps, as well as that it may work better than the current implementation anyways.


  • gravelldgravelld Administrator

    Other than the bugs listed below, Web -> mobile play queue sync is implemented. As far as I can tell we do already do this, but I think I'm missing something...

    Regarding "continue from where you left off"...

    Here's what needs to be in place for the "continue from where you left off" message to come up:

    • In compliance with Subsonic requirements, the Astiga server needs to advertise itself as at least version 1.12 (it does).
    • The preference neverResumePlayQueue must be false or unset.
    • The local play queue must have been changed before the remote one.

    For that last point, note that there's the issue that (I consider this a bug) the Web app's play queue is only saved every five minutes, regardless of adding or removing from the play queue. So whatever happens, once you change the play queue you have to leave the Web app open for five minutes for that to show up later when using the app.

    neverResumePlayQueue cannot be unset in the app, which is also a bug really. The only way to unset it is to use Settings to Manage apps and delete data. But that also deletes your account linked, so that's not much good. I think we need to implement the solutions discussed here:

  • Regarding that message, that's for the Astiga app right?

    When I use the Astiga app, phone -> web works just fine. Web -> phone doesn't. Also, removing all app data to unset the variable stoped working over a year ago, I haven't been able to get it to re-appear ever since. I'm near certain I mentioned this once back then. But I kinda gave up on it by now really, which is a shame as it's a feature I do miss. But I just couldn't get it to pop back up no matter what I tried.

    Leaving it open for at least 5 min is no issue, I never edit the tracklist just before closing. I generally just want to take my current tracklist with me while switching devices.

    However, that's not what this topic is about. This setting is in the Tempo app. Even when it's on, neither phone -> web nor web -> phobe works. I'm assuming Astiga has it's own implementation to sync this que and isn't compatible with the "regular" SubSonic one the Tempo app supports. Hence me making this topic suggesting maybe you could look into getting that to work, both to increase SubSonic-app compatibility and the issues with the current sync.

  • gravelldgravelld Administrator

    I would like to fix that Web -> app sync because there's no reason why it shouldn't work. It looks like your play queue was last edited at 8:21 GMT. If you restart the app and the play queue there was last edited before that time it should work.

    For Tempo, I enabled the option and watched what it did. As far as I can see Astiga is playing nicely, so I created a bug:

    I hope I'm understanding your issue.

  • I have to admit, I don't have the app installed currently as I try to minimise the use of apps that require Aurora Store/Google Play Store/anything Google and switched to Tempo for now as I can get it trough F-Droid with the IzzyOnDroid repro.

    I could try installing it again, but as I have a as far as possible de-googled phone by now (which I did after I gave up, so it's not the cause itself) it might not be the best testing device.

  • gravelldgravelld Administrator

    Don't worry about it!

Sign In or Register to comment.