Shuffle artist never starts

davvvddavvvd Member

On the Android app, selecting Shuffle on an artist brings up a Contacting Server progress animation which never goes away, and music never starts playing. I left it up for several minutes.

Comments

  • gravelldgravelld Administrator

    Is this the only thing that shows "Contacting Server" - can you play individual tracks, playlists or full albums?

  • davvvddavvvd Member

    Yes, I can play those. I can shuffle albums and playlists as well.

  • gravelldgravelld Administrator

    Is it consistent across all artists? Can you find an artist with a very small number of tracks and shuffle them?

  • davvvddavvvd Member

    Shuffling an artist with only a few tracks seems to work. Artists with lots of tracks are the only ones that seem to have this issue.

  • gravelldgravelld Administrator

    Ok, thanks, can you give me an example artist from your collection (send it via email to info@ if you would rather not share).

  • davvvddavvvd Member

    You can use Lemon Demon as an example. Open their artist page, tap the ellipsis button in the top right, and choose Shuffle.

  • gravelldgravelld Administrator

    Ok, I'll have to look at that next week.

  • gravelldgravelld Administrator

    Ok, I can see what happens I think.

    When I run this on my development workstation, I can see that all the tracks get duplicated. This causes a lot of network traffic. It takes a good few seconds but eventually it does return.

    Could you be seeing something similar, only it is exacerbated by a slower network?

    Anyway, if that is the issue I think it is caused by the playlist actually being double the size to that which it should be. The tracklist is duplicated in a similar manner to https://community.asti.ga/discussion/469/play-album-adds-2-copies-of-album-to-playlist .

  • davvvddavvvd Member

    I've got a gigabit fiber connection so I don't think it's a slow network issue. Also it was taking over 5 minutes for me (after 5 minutes I gave up and hit the Back button on my phone).

  • gravelldgravelld Administrator

    Hmmm. Well what I outlined is a problem, but maybe it's not the problem here. I think I might have to issue you a build with more logging to look into what's going on. This might take a while, not least because I'm away for a few days. Could you tell me your Android version and what hardware you're using?

  • davvvddavvvd Member

    I'm on a Samsung Galaxy S10 with Android 12.

  • gravelldgravelld Administrator

    Thanks 👍️

Sign In or Register to comment.